LxCenter HyperVM & Kloxo Support

Forum is closed. Use http://community.lxcenter.org/



Members   Search      Help    Register    Login    Home
Home » HyperVM Community Support » Windows under Xen » $MFT has invalid magic - Rebuild win vps failed
$MFT has invalid magic - Rebuild win vps failed [message #31674] Sun, 15 June 2008 04:39
seflow is currently offline seflow  Italy
Messages: 27
Registered: July 2007
Location: Milan
Member
hi,
with latest build 3742 i have some issue with windows vps restoration and resource modification.

i can create successfully OStemplate of windows 2008 but when i try a rebuild or try to create new windows vps the process still in progress for hours and i must kill by hands.

Analyzing the problem seems that program ntfsclone never stop and if i kill it the partition was corrupt.

In shell exec i found some error like:

[(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'xm'  'mem-set' 'winvps2.vm' '512']
1: 17:24 Jun/15/2008: CLosed Exec output:   VolGroup00:r/w:772:-1:0:3:2:-1:0:1:1:285343744:32768:8708:3052:565$
 :  /usr/local/lxlabs/hypervm/cexe/closeallinput 'vgdisplay -c VolGroup00'
1: 17:24 Jun/15/2008: 0: File descriptor 3 left open
File descriptor 4 left open
File descriptor 6 left open
 [(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'lvcreate'  '-L15000M' '-nwinvps2_rootimg' 'VolGroup00']
1: 17:24 Jun/15/2008: 0:  [(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'parted'  '-s' '/dev/VolGroup00/win$
1: 17:24 Jun/15/2008: 1:  [(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'parted'  '-s' '/dev/VolGroup00/win$
1: 17:24 Jun/15/2008: 0:  [(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'parted'  '-s' '/dev/VolGroup00/win$
1: 17:24 Jun/15/2008: 0:  [(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'parted'  '-s' '/dev/VolGroup00/win$
1: 17:24 Jun/15/2008: 0:  [(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'kpartx'  '-a' '/dev/mapper/VolGrou$
1: 17:24 Jun/15/2008: 0:  [(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'kpartx'  '-l' '/dev/mapper/VolGrou$
1: 17:24 Jun/15/2008: 1: $MFT has invalid magic.
ntfs_mft_load(): Failed.
Failed to load $MFT: Input/output error.
Failed to startup volume: Input/output error.
$MFT has invalid magic.
ntfs_mft_load(): Failed.
Failed to load $MFT: Input/output error.
Failed to startup volume: Input/output error.
Volume is corrupt. You should run chkdsk.
 [(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'ntfsfix'  '/dev/mapper/VolGroup00-winvps2_rootimg1']


in shell_error

1: 17:23 Jun/15/2008: : [(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'kpartx'  '-d' '/dev/mapper/VolGroup0$
1: 17:23 Jun/15/2008: : [(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'kpartx'  '-a' '/dev/mapper/VolGroup0$
1: 17:23 Jun/15/2008: : [(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'kpartx'  '-l' '/dev/mapper/VolGroup0$
1: 17:23 Jun/15/2008: The device /dev/mapper/failed doesn't exist
: [(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'ntfscluster'  '-f' '/dev/mapper/failed']
1: 17:23 Jun/15/2008: : [(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'kpartx'  '-d' '/dev/mapper/VolGroup0$
1: 17:24 Jun/15/2008: Error: Domain 'winvps2.vm' does not exist.
: [(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'xm'  'mem-set' 'winvps2.vm' '512']
1: 17:24 Jun/15/2008: : [(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'parted'  '-s' '/dev/VolGroup00/winvp$
1: 17:24 Jun/15/2008: $MFT has invalid magic.
ntfs_mft_load(): Failed.
Failed to load $MFT: Input/output error.
Failed to startup volume: Input/output error.
$MFT has invalid magic.
ntfs_mft_load(): Failed.
Failed to load $MFT: Input/output error.
Failed to startup volume: Input/output error.
Volume is corrupt. You should run chkdsk.
: [(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'ntfsfix'  '/dev/mapper/VolGroup00-winvps2_rootimg1']
1: 17:25 Jun/15/2008: $MFT has invalid magic.
ntfs_mft_load(): Failed.
Failed to load $MFT: Input/output error.
Failed to startup volume: Input/output error.
Failed to mount '/dev/mapper/VolGroup00-winvps2_rootimg1': Input/output error.
NTFS is inconsistent. Run chkdsk /f on Windows then reboot it TWICE!
The usage of the /f parameter is very IMPORTANT! No modification was
made to NTFS by this software.
: [(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'ntfscluster'  '-f' '/dev/mapper/VolGroup00-winvps2_rootimg$
1: 17:27 Jun/15/2008: $MFT has invalid magic.
ntfs_mft_load(): Failed.
Failed to load $MFT: Input/output error.
Failed to startup volume: Input/output error.
Failed to mount '/dev/mapper/VolGroup00-winvps2_rootimg1': Input/output error.
NTFS is inconsistent. Run chkdsk /f on Windows then reboot it TWICE!
The usage of the /f parameter is very IMPORTANT! No modification was
made to NTFS by this software.
: [(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'ntfscluster'  '-f' '/dev/mapper/VolGroup00-winvps2_rootimg$
1: 17:27 Jun/15/2008: $MFT has invalid magic.
ntfs_mft_load(): Failed.
Failed to load $MFT: Input/output error.
Failed to startup volume: Input/output error.
Failed to mount '/dev/mapper/VolGroup00-winvps2_rootimg1': Input/output error.
NTFS is inconsistent. Run chkdsk /f on Windows then reboot it TWICE!
The usage of the /f parameter is very IMPORTANT! No modification was
made to NTFS by this software.
: [(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'ntfscluster'  '-f' '/dev/mapper/VolGroup00-winvps2_rootimg$
1: 17:28 Jun/15/2008: $MFT has invalid magic.
ntfs_mft_load(): Failed.
Failed to load $MFT: Input/output error.
Failed to startup volume: Input/output error.
Failed to mount '/dev/mapper/VolGroup00-winvps2_rootimg1': Input/output error.
NTFS is inconsistent. Run chkdsk /f on Windows then reboot it TWICE!
The usage of the /f parameter is very IMPORTANT! No modification was
made to NTFS by this software.
: [(__system__:/usr/local/lxlabs/hypervm/httpdocs) 'ntfscluster'  '-f' '/dev/mapper/VolGroup00-winvps2_rootimg$
1: 17:31 Jun/15/2008: $MFT has invalid magic.
ntfs_mft_load(): Failed.
Failed to load $MFT: Input/output error.
Failed to startup volume: Input/output error.
Failed to mount '/dev/mapper/VolGroup00-winvps2_rootimg1': Input/output error.
....


i tryed with different OStemplate without success.

Another problem is if i try to increase hdd resource i see same problem and vps will start to bee inconsistent.


Matteo Berlonghi - matteob@seflow.net WebFarm Manager http://www.SeFlow.it Virtual & Dedicated Professional Hosting

[Updated on: Sun, 15 June 2008 04:44]

Report message to a moderator

Previous Topic: Restarting the backend. Please try again after 30 seconds.
Next Topic:Add new HD for LVM (RESOLVED)
Goto Forum:
  


Current Time: Tue Oct 21 05:00:02 EDT 2014

Total time taken to generate the page: 0.01632 seconds
.:: Contact :: Home :: Privacy ::.

Click here to lend your support to: LxCenter and make a donation at www.pledgie.com !

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software