LxCenter HyperVM & Kloxo Support

Forum is closed. Use http://community.lxcenter.org/



Members   Search      Help    Register    Login    Home
Home » Archive » HyperVM Bug Reports » [bug] Timezones on Xen
[bug] Timezones on Xen [message #40237] Sun, 05 October 2008 19:03 Go to next message
Chris E is currently offline Chris E  United Kingdom
Messages: 409
Registered: October 2007
Location: United Kingdom
Master
When we reboot a VPS in HyperVM the timezone is overwritten.

/etc/localtime is overwritten with a COPY of usr/share/zoneinfo/America/New_York, not a symlink.

The timezone change tool also does not work properly.

It also seems that if we set the timezone manually in the vps e.g. ln -s /usr/share/zoneinfo/GB /etc/localtime, that file is overwritten after a reboot

Please change it so that the timezone is not changed on each reboot in hypervm, incase the customer sets the timezone in their VPS manually

Thanks


Regards,
Chris E
Hire me for HyperVM/Xen Support & Templates: Click Here
[hvmbug] Re: Timezones on Xen [message #40263 is a reply to message #40237] Mon, 06 October 2008 02:37 Go to previous messageGo to next message
Lxhelp
Messages: 23689
Registered: July 2006
The Champion
Yes, currently it is set at every boot. We will need to implement something similar to our current root-pass logic, where the file in the VPS is reset only if the vps-owner makes any changes via the CP.

thanks.


On Sun, Oct 05, 2008 at 11:03:49PM -0000, Chris wrote:
>
>
> When we reboot a VPS in HyperVM the timezone is overwritten.
>
> /etc/localtime is overwritten with a COPY of usr/share/zoneinfo/America/New_York, not a symlink.
Re: [bug] Timezones on Xen [message #40280 is a reply to message #40237] Mon, 06 October 2008 04:05 Go to previous messageGo to next message
Chris E is currently offline Chris E  United Kingdom
Messages: 409
Registered: October 2007
Location: United Kingdom
Master
Can you also please make it so that it changes the timezone via symlink rather than copying the actual timezone file as /etc/localtime ?

Regards,
Chris E
Hire me for HyperVM/Xen Support & Templates: Click Here
[hvmbug] Re: Timezones on Xen [message #40475 is a reply to message #40280] Tue, 07 October 2008 04:21 Go to previous messageGo to next message
Lxhelp
Messages: 23689
Registered: July 2006
The Champion
yes, we will switch to linking itself. That way you will be able to find the timezone by doing an ls -al.

thanks.


On Mon, Oct 06, 2008 at 08:05:40AM -0000, Chris wrote:
>
>
> Can you also please make it so that it changes the timezone via symlink rather than copying the actual timezone file as /etc/localtime ?
[hvmbug] Re: Timezones on Xen [message #40552 is a reply to message #40475] Tue, 07 October 2008 12:46 Go to previous messageGo to next message
Lxhelp
Messages: 23689
Registered: July 2006
The Champion
This is fixed. From now on, hyperVM will symlink the zonefile to /etc/localtime.

thanks.

Quote:


>
> On Mon, Oct 06, 2008 at 08:05:40AM -0000, Chris wrote:
> >
> >
> > Can you also please make it so that it changes the timezone via symlink rather than copying the actual timezone file as /etc/localtime ?




Re: [bug] Timezones on Xen [message #41268 is a reply to message #40237] Sun, 12 October 2008 07:36 Go to previous messageGo to next message
hpham is currently offline hpham  Vietnam
Messages: 390
Registered: November 2007
Location: the net
Master
in VPS
# ls -l /etc/localtime
lrwxrwxrwx 1 root root 22 Oct 12 04:32 /etc/localtime -> ../usr/share/zoneinfo/
# date
Sun Oct 12 11:35:24 UTC 2008


in the node
# ls -l /etc/localtime
lrwxrwxrwx 1 root root 31 Oct 10 08:15 /etc/localtime -> /usr/share/zoneinfo/Asia/Saigon
# date
Sun Oct 12 18:35:34 ICT 2008


So, it's still different timezone between node and VPS. How to synchronize automatically?
Re: Timezones on Xen [message #41269 is a reply to message #41268] Sun, 12 October 2008 07:38 Go to previous messageGo to next message
Lxhelp
Messages: 23689
Registered: July 2006
The Champion
Go to vps home -> timezone and set it there.

thanks.


On Sun, Oct 12, 2008 at 11:36:39AM -0000, hpm77 wrote:
>
>
> in VPS


Re: [bug] Timezones on Xen [message #41270 is a reply to message #40237] Sun, 12 October 2008 07:59 Go to previous messageGo to next message
hpham is currently offline hpham  Vietnam
Messages: 390
Registered: November 2007
Location: the net
Master
Have set the timezone in vpshome, then reboot vps, but it's still not corrected

# date
Sun Oct 12 11:58:35 UTC 2008
# ls -l /etc/localtime
lrwxrwxrwx 1 root root 22 Oct  8 20:54 /etc/localtime -> ../usr/share/zoneinfo/
Re: Timezones on Xen [message #41271 is a reply to message #41268] Sun, 12 October 2008 08:04 Go to previous messageGo to next message
Lxhelp
Messages: 23689
Registered: July 2006
The Champion
Can you do this:

 
 echo "select timezone from vps where nname = 'vps.vm'" | hypervmdb
 



On Sun, Oct 12, 2008 at 11:36:39AM -0000, hpm77 wrote:
>


Re: [bug] Timezones on Xen [message #41272 is a reply to message #40237] Sun, 12 October 2008 08:09 Go to previous messageGo to next message
hpham is currently offline hpham  Vietnam
Messages: 390
Registered: November 2007
Location: the net
Master
it's correctly in hypervm database, but not in VPS
# echo "select timezone from vps where nname = 'xxxxx.vm'" | hypervmdb
timezone
Asia/Saigon
Re: Timezones on Xen [message #41273 is a reply to message #41272] Sun, 12 October 2008 08:13 Go to previous messageGo to next message
Lxhelp
Messages: 23689
Registered: July 2006
The Champion
Can you please update hypervm to the latest version, and try again?

thanks.


On Sun, Oct 12, 2008 at 12:09:03PM -0000, hpm77 wrote:
>
>
> it's correctly in hypervm database, but not in VPS
> # echo "select timezone from vps where nname = 'xxxxx.vm'" | hypervmdb
> timezone
> Asia/Saigon
>
>


Re: [bug] Timezones on Xen [message #41276 is a reply to message #40237] Sun, 12 October 2008 08:33 Go to previous messageGo to next message
hpham is currently offline hpham  Vietnam
Messages: 390
Registered: November 2007
Location: the net
Master
updated to the latest version
 Current Version:   2.0.6102
Latest Version:   2.0.6102

updated timezone in vps home again, then reboot vps. Still point to /usr/share/zoneinfo/ only

# date
Sun Oct 12 12:31:51 UTC 2008
# ls -l /etc/localtime
lrwxrwxrwx 1 root root 22 Oct  8 20:54 /etc/localtime -> ../usr/share/zoneinfo/


# echo "select timezone from vps where nname = 'xxxxx.vm'" | hypervmdb
timezone
Asia/Saigon

Re: [bug] Timezones on Xen [message #41495 is a reply to message #40237] Tue, 14 October 2008 00:00 Go to previous messageGo to next message
hpham is currently offline hpham  Vietnam
Messages: 390
Registered: November 2007
Location: the net
Master
any update on this please?
Re: [bug] Timezones on Xen [message #44321 is a reply to message #40237] Sun, 02 November 2008 21:51 Go to previous messageGo to next message
hpham is currently offline hpham  Vietnam
Messages: 390
Registered: November 2007
Location: the net
Master
Is there any update on this? I just tried to reboot one VPS and the issue is still remaining.

Re: Timezones on Xen [message #44346 is a reply to message #44321] Mon, 03 November 2008 04:09 Go to previous messageGo to next message
Lxhelp
Messages: 23689
Registered: July 2006
The Champion
Update to the latest version, and then do this:

 
 /script/vps/reboot vps.vm
 


Then wait for sometime, and then check:

 
 tail -f /usr/local/lxlabs/hypervm/log/localtime
 


ON THE SLAVE, and see what's the command registered there.

On Mon, Nov 03, 2008 at 02:51:57AM -0000, hpm77 wrote:
>
>
> Is there any update on this? I just tried to reboot one VPS and the issue is still remaining.
>
>
>


Re: Timezones on Xen [message #44347 is a reply to message #44321] Mon, 03 November 2008 04:14 Go to previous messageGo to next message
Lxhelp
Messages: 23689
Registered: July 2006
The Champion
Did you actually set the timezone by going to vps home -> timezone

What you say would happen only if the timezone field is emtpy. You should set the timezone forcibly once, and then reboot the vps.


On Mon, Nov 03, 2008 at 02:51:57AM -0000, hpm77 wrote:
>
>
> Is there any update on this? I just tried to reboot one VPS and the issue is still remaining.
>
>
>


Re: Timezones on Xen [message #44373 is a reply to message #44346] Mon, 03 November 2008 05:45 Go to previous messageGo to next message
hpham is currently offline hpham  Vietnam
Messages: 390
Registered: November 2007
Location: the net
Master
Lxhelp wrote on Mon, 03 November 2008 16:09

Update to the latest version

Current Version: 2.0.6352
Latest Version: 2.0.6352

Lxhelp wrote on Mon, 03 November 2008 16:09


Then wait for sometime, and then check:

 
 tail -f /usr/local/lxlabs/hypervm/log/localtime
 


ON THE SLAVE, and see what's the command registered there.



# tail -f /usr/local/lxlabs/hypervm/log/localtime
1: 17:41 Nov/03/2008: ln -sf '../usr/share/zoneinfo/Asia/Saigon' /home/xen/xxxxxx.vm/mnt/etc/localtime


Lxhelp wrote on Mon, 03 November 2008 16:14

Did you actually set the timezone by going to vps home -> timezone


Yes, I do update in vps home -> timezone already, as mentioned above.

And now the result in VPS

# ls -l /etc/localtime
lrwxrwxrwx 1 root root 22 Oct  8 20:54 /etc/localtime -> ../usr/share/zoneinfo/
# date
Mon Nov  3 10:42:27 UTC 2008

It's still set to UTC time zone. No change!
Re: Timezones on Xen [message #44379 is a reply to message #44373] Mon, 03 November 2008 06:14 Go to previous messageGo to next message
Lxhelp
Messages: 23689
Registered: July 2006
The Champion
Update to the latest version and reboot again.

 
 /script/upcp
 /script/vps/reboot vps.vm
 


And check the localtime log file.


On Mon, Nov 03, 2008 at 10:45:29AM -0000, hpm77 wrote:
>
>
> Lxhelp wrote on Mon, 03 November 2008 16:09
> > Update to the latest version


Re: [bug] Timezones on Xen [message #44396 is a reply to message #40237] Mon, 03 November 2008 07:17 Go to previous message
hpham is currently offline hpham  Vietnam
Messages: 390
Registered: November 2007
Location: the net
Master
Yes, it seems correct this time. Rebooting VPS, and it can keep the settings.

In the localtime log, I see the same thing, with a new line "NULL".

1: 19:14 Nov/03/2008: ln -sf '../usr/share/zoneinfo/Asia/Saigon' /home/xen/xxxxxx.vm/mnt/etc/localtime
1: 19:14 Nov/03/2008: NULL


So, where is the issue located?
Thanks.
Previous Topic:Node loadavg doesn't show
Next Topic:Zend issues
Goto Forum:
  


Current Time: Tue Sep 23 14:15:43 EDT 2014

Total time taken to generate the page: 0.01884 seconds
.:: Contact :: Home :: Privacy ::.

Click here to lend your support to: LxCenter and make a donation at www.pledgie.com !

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software